无忧启动论坛

 找回密码
 注册
搜索
最纯净的「微PE装机优盘」UEPON大师作品系统gho:最纯净好用系统下载站数据恢复、数据保护、视频编辑
Win To Go 极致利器(IXUNCIS固态U盘)无忧启动网成立20周年!广告联系 QQ:184822951 微信:wuyouceo
楼主: 星体投射

[分享] 支持XP/03的nvme驱动

    [复制链接]
发表于 2019-3-20 22:18:55 | 显示全部楼层
yun2673436976 发表于 2019-3-19 10:32
Windows2003 32位企业版装在x99平台支 i7 6六代平台支玩大型3D游戏吗性能有什么影响不?比如古墓丽影  ...


    主打游戏的话,个人觉得不是很合适,毕竟只支持到DX9。
    此外,游戏的主要决定因素是显卡。据说修改版驱动最高支持到GTX1080(GP104),我没有这个卡,具体情况不清楚。

点评

买了1080的显卡,通过改驱动让XP支持1080P,这不可能啊。8代U 没有WIN7核显,要改WIN10核显才能让WIN7在没有独立显卡的前提下使用8代U核显的方法都不是很完美,更何况是年代久远的XP。  详情 回复 发表于 2019-3-25 01:17
回复

使用道具 举报

发表于 2019-3-24 23:54:10 | 显示全部楼层
我在XP或是WS2003SP2下都找不到storport.sys
回复

使用道具 举报

发表于 2019-3-25 01:17:15 | 显示全部楼层
aday 发表于 2019-3-20 22:18
主打游戏的话,个人觉得不是很合适,毕竟只支持到DX9。
    此外,游戏的主要决定因素是显卡。据 ...

买了1080的显卡,通过改驱动让XP支持1080P,这不可能啊。8代U 没有WIN7核显,要改WIN10核显才能让WIN7在没有独立显卡的前提下使用8代U核显的方法都不是很完美,更何况是年代久远的XP。
回复

使用道具 举报

发表于 2019-4-13 12:40:04 | 显示全部楼层
实测三星SM951在64位XP下安装此驱动后可用,另外设备管理器中显示的名称可以在nvme.inf里“CommNvme.DeviceDesc=”段的双引号内自由修改。
截图.jpg
截图.jpg
回复

使用道具 举报

发表于 2019-4-13 12:46:25 | 显示全部楼层
感谢热心朋友搬运
回复

使用道具 举报

发表于 2019-4-30 22:13:43 | 显示全部楼层
本帖最后由 yu13740000 于 2019-5-1 12:36 编辑

各位高手,谁能说说具体安装流程吗,不知道怎么安装,谢谢了!
h110s2主板三星sm961硬盘,主板找不到兼容模式,xp启动后找不到盘蓝屏,不知道如何注入nvme驱动。

@朱玛12345678
回复

使用道具 举报

发表于 2019-5-1 12:56:19 | 显示全部楼层
aday 发表于 2018-8-23 20:13
不错,测试可用,感谢LZ提供。

请问如何安装啊,我主板直接安装蓝屏,不知道如何吧这个驱动集成

点评

我尝试用nLite集成没有成功,安装认不出960PRO。 但是通过其它办法也解决了:在SATA盘上安装系统,打NVME驱动, 1、用傲梅【系统迁移】迁移到960PRO即可。 2、做GHOST,然后恢复到960PRO分区上  详情 回复 发表于 2019-5-4 13:24
回复

使用道具 举报

发表于 2019-5-1 13:02:29 | 显示全部楼层
seiise 发表于 2018-12-30 15:06
这个驱动可以了,XP/03里面速度飞快!

请问如何安装啊,我主板h110s2直接安装找不到盘蓝屏,不知道如何吧这个驱动集成
回复

使用道具 举报

发表于 2019-5-4 13:24:05 | 显示全部楼层
yu13740000 发表于 2019-5-1 12:56
请问如何安装啊,我主板直接安装蓝屏,不知道如何吧这个驱动集成


    我尝试用nLite集成没有成功,安装认不出960PRO。
    但是通过其它办法也解决了:在SATA盘上安装系统,打NVME驱动,
    1、用傲梅【系统迁移】迁移到960PRO即可。
    2、做GHOST,然后恢复到960PRO分区上即可。

    到目前为止,使用没有遇到任何问题。
    唯一的区别大概因为系统节能或驱动的原因,2003上的温度比Win10上高大约10度,我是2003/10双系统,都在960PRO上。

snap039.png

回复

使用道具 举报

发表于 2019-5-4 16:54:54 | 显示全部楼层
aday 发表于 2019-5-4 13:24
我尝试用nLite集成没有成功,安装认不出960PRO。
    但是通过其它办法也解决了:在SATA盘上安装 ...


在论坛小哥朱玛12345678的协助下,折腾了2天,未能成功。主板华硕h110s和三星sm961硬盘可能太新,用普通的SATA固态硬盘安装xp的32和2003R2的32位打上AHCI驱动能进系统,但是驱动缺失太多都不能打齐,nvme驱动反复折腾多次,都装不上,按照作者的方法也试过,都是装不上。
      
不知道你们成功的都是啥主板和ssd。

点评

XP/2003的AHCI驱动用我截图中的MOD驱动非常好用,大神也一直在同步更新,目前支持到300系和X299系: https://www.win-raid.com/t11f23-Modded-Intel-AHCI-and-RAID-Drivers-digitally-signed.html 我目  详情 回复 发表于 2019-5-4 21:09
回复

使用道具 举报

发表于 2019-5-4 21:09:59 | 显示全部楼层
本帖最后由 aday 于 2019-5-4 21:13 编辑
yu13740000 发表于 2019-5-4 16:54
在论坛小哥朱玛12345678的协助下,折腾了2天,未能成功。主板华硕h110s和三星sm961硬盘可能太新,用普 ...


    XP/2003的AHCI驱动用我上面截图中的MOD驱动非常好用,大神也一直在同步更新,目前支持到INTEL300系和X299:
https://www.win-raid.com/t11f23- ... gitally-signed.html

   我目前的平台是X99,1个M.2-960PRO,3个SATA SSD。

snap040.png

点评

无法下载啊  详情 回复 发表于 2020-1-12 00:11
回复

使用道具 举报

发表于 2019-5-4 21:32:02 | 显示全部楼层
感谢热心朋友搬运。
回复

使用道具 举报

发表于 2019-5-7 08:05:50 | 显示全部楼层
等后续nvme驱动更新后再试试看,现在就卡在nvme驱动上,sata硬盘AHCI驱动没啥问题
回复

使用道具 举报

发表于 2019-5-7 08:13:45 | 显示全部楼层
aday 发表于 2019-5-4 21:09
XP/2003的AHCI驱动用我上面截图中的MOD驱动非常好用,大神也一直在同步更新,目前支持到INTEL300系 ...

会不会sm961的硬件id没写进nvme驱动?那位作者也是960的,所以你960能直驱

点评

应该不是,去年刚看到这个驱动我是用威刚的盘做的测试,也没问题,见33楼。 真要说区别的话,我用的两条都是零售版,而SM961是OEM。 大神改的是通用驱动,应该是不需要、也不会写具体的硬件ID进去  详情 回复 发表于 2019-5-7 23:42
回复

使用道具 举报

发表于 2019-5-7 23:42:03 | 显示全部楼层
yu13740000 发表于 2019-5-7 08:13
会不会sm961的硬件id没写进nvme驱动?那位作者也是960的,所以你960能直驱


    应该不是,去年刚看到这个驱动我是用威刚的盘做的测试,也没问题,见33楼。
    真要说区别的话,我用的两条都是零售版,而SM961是OEM。

    大神改的是通用驱动,应该是不需要、也不会写具体的硬件ID进去的。

回复

使用道具 举报

发表于 2019-5-8 16:02:28 | 显示全部楼层
有道理,极有可能是sm961是oem版的原因,给作者留言了,看看有没有后续
回复

使用道具 举报

发表于 2019-5-13 01:46:24 | 显示全部楼层
好东西,太给力,支持下。
回复

使用道具 举报

发表于 2019-6-12 07:34:55 | 显示全部楼层
非常好的驱动,收藏先!
回复

使用道具 举报

发表于 2019-6-12 08:30:04 | 显示全部楼层
这个厉害了!感谢分享
回复

使用道具 举报

发表于 2019-6-30 19:11:50 | 显示全部楼层
seiise 发表于 2018-12-30 15:21
找了个老版网虫03PE,也测试成功了。今后nvme盘安装XP或03不再是瓶颈.


PE是不是这样写的

添加


[SourceDisksFiles]
nvme.sys=1,,,,,,4_,4,1,,,1,4

[HardwareIdsDatabase]
PCI\CC_010802="nvme"

[SCSI.Load]
nvme=nvme.sys

[SCSI]
nvme = "Community NVMe 1.3 Storport Miniport by Schtrom"
回复

使用道具 举报

发表于 2019-6-30 22:43:50 | 显示全部楼层
红毛樱木 发表于 2018-11-1 01:00
VmWare 15测试不行,有人能联系到作者吗?
sourceforge.net的帐号老是注册失败- -

Oracle VM VirtualBox 5.2.30 也不行,安装后死机,和46楼的一个现象。

点评

用win10也无法启用nvme,应该是VirtualBox虚拟的问题了,。。  详情 回复 发表于 2019-7-2 09:49
回复

使用道具 举报

发表于 2019-7-2 09:49:46 | 显示全部楼层
h2bx86 发表于 2019-6-30 22:43
Oracle VM VirtualBox 5.2.30 也不行,安装后死机,和46楼的一个现象。

用win10也无法启用nvme,应该是VirtualBox虚拟的问题了,。。
回复

使用道具 举报

发表于 2019-7-2 10:51:19 | 显示全部楼层
1.3 nvme.inf是不是写错了个参数?

HKR, "Parameters", "BusType", %REG_DWORD%, 0x00000001

应该改为-->

HKR, "Parameters", "BusType", %REG_DWORD%, 0x00000011

点评

细心,非常赞同。  详情 回复 发表于 2019-9-3 10:55
回复

使用道具 举报

发表于 2019-7-30 09:40:27 | 显示全部楼层
aday 发表于 2019-5-4 13:24
我尝试用nLite集成没有成功,安装认不出960PRO。
    但是通过其它办法也解决了:在SATA盘上安装 ...

用什么方法打驱动呢,我集成了也用不了
回复

使用道具 举报

发表于 2019-7-30 10:44:26 | 显示全部楼层
aday 发表于 2018-8-23 20:13
不错,测试可用,感谢LZ提供。

怎么打驱动呢
回复

使用道具 举报

发表于 2019-8-18 10:58:48 | 显示全部楼层
32位xp已测试成功安装
回复

使用道具 举报

发表于 2019-8-20 20:19:29 来自手机 | 显示全部楼层
win200测试成功
回复

使用道具 举报

发表于 2019-8-24 20:49:41 | 显示全部楼层
感谢分享
回复

使用道具 举报

发表于 2019-9-3 10:55:53 | 显示全部楼层
h2bx86 发表于 2019-7-2 10:51
1.3 nvme.inf是不是写错了个参数?

HKR, "Parameters", "BusType", %REG_DWORD%, 0x00000001

细心,非常赞同。
回复

使用道具 举报

发表于 2019-12-14 08:28:21 | 显示全部楼层
xiazaibuliao
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|捐助支持|无忧启动 ( 闽ICP备05002490号-1 )

闽公网安备 35020302032614号

GMT+8, 2020-12-2 23:46

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表